Skip to content

Migration vers Ubuntu 10.10 problème driver Nvidia

25 octobre 2010

Avant de tenter la méthode suivante, voyez si celle-ci fonctionne : https://mementolinux.wordpress.com/2010/04/22/ubuntu-10-04-probleme-driver-nvidia/

Lors de ma dernière migration, j’avais déjà eu des soucis avec l’affichage après migration.
Ce coup-ci, impossible de démarrer Ubuntu normalement et je finis en mode console.

En jetant, un œil dans les logs de Xorg, je vois des erreurs:

cat /var/log/xorg.0.log | grep EE

Je reboot (sudo reboot) et démarre en failsafeX. J’essaie de désinstaller le driver nvidia par le menu système…Ça ne marche pas.
Je passe en mode bourrin:

sudo apt-get remove nvdia*
sudo gedit /etc/X11/xorg.cong
# faîtes éventuellement une sauvegarde préalable de ce fichier

Dans le xorg.conf, je modifie Driver "nvidia" par Driver "vesa". Ce coup-ci les redémarrages fonctionnent.
Donc je reboot.

J’essaie de réinstaller le pilote propriétaire par le menu système… Échec, il ne trouve pas de driver. Cependant, ça peut fonctionner chez vous!
Du coup, méthode bourrin:

sudo apt-get install nvidia96
# Attention, votre driver peut être nvidiaXXX et non nvidia96

Et j’active le driver par le menu système qui ce coup-ci le détecte: Système -> Administration -> Pilotes supplémentaires, et cliquez sur activer.
Bon, ce n’était probablement la méthode élégante, mais ça fonctionne.

No comments yet

Laisser un commentaire

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s

%d blogueurs aiment cette page :